integ/ostree/initramfs-ostree/debian/deb_patches/0003-Add-lvm2-package-to-initramfs.patch
Robert Church 364acf2f20 debian: initramfs-ostree - Initial AIO partition/format support
Add temporary installer support for creating default filesystem
configuration for AIOs. This will create the following based on the
current AIO CentOS kickstart settings for large disks:

- Platform backup partition/filesystem
- Default physical volume and volume group for cgts-vg
- Logical volumes for log-lv and scratch-lv
- Format platform backup, log, and scratch filesystem as ext4

Test Plan (using 512G root disk):
 - PASS: Build/Install ISO
 - PASS: Observe correct partitions, physical volume, volume group,
         logical volumes present after boot
 - PASS: Reinstall ISO after successful install

Note: /etc/fstab is updated as a post-rootfs script in
base-bullseye.yaml

Story: 2009101
Task: 44398
Signed-off-by: Robert Church <robert.church@windriver.com>
Change-Id: I6fb3f5bcd26f9035327fb614a34b8fc35ea64362
2022-02-02 06:38:09 -05:00

31 lines
1.0 KiB
Diff

From d0aca679be610c4dbb8b3977be335f8d0dcd5e03 Mon Sep 17 00:00:00 2001
From: Robert Church <robert.church@windriver.com>
Date: Tue, 1 Feb 2022 03:13:15 -0500
Subject: [PATCH 3/3] Add lvm2 package to initramfs
LVM will be used to set up the minimal StarlingX volume group. Include
the package in the Depends list so that vgcreate, pvcreate, lvcreate
commands are available for provisioning.
Signed-off-by: Robert Church <robert.church@windriver.com>
---
debian/control | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/debian/control b/debian/control
index 002f25a..899bbb2 100644
--- a/debian/control
+++ b/debian/control
@@ -25,7 +25,7 @@ Homepage: https://github.com/WindRiver-Labs/meta-lat
Package: initramfs-ostree
Architecture: all
-Depends: gdisk, e2fsprogs, ${misc:Depends}, ${shlibs:Depends}
+Depends: gdisk, e2fsprogs, lvm2, ${misc:Depends}, ${shlibs:Depends}
Multi-Arch: foreign
Description: Init for initramfs to mount ostree
Basic init for initramfs to mount ostree and pivot root
--
2.16.6