integ/config/puppet-5.5.22/debian/deb_patches/0001-Remove-default-hiera-config.patch
Robert Church 1d31c4dd06 debian: Correctly install the StarlingX puppet.conf
The upstream Debian package provides its own puppet.conf and hiera.yaml
files. The puppet.conf file is being installed and is overwriting the
desired patched puppet.conf file from the source patch
0005-Set-strict-variables-and-basemodulepath-in-puppet.co.patch.

Move the desired content to conffiles/puppet.conf, drop the source
patch, and allow the existing install directives to install the
StarlingX content.

This packaging should be revisited in the future to update
conffiles/hiera.yaml for what is required by StarlingX . This should
install the hiera.yaml (converted to v5) from the stx-puppet package and
drop the change from that package.

This should provide ordering compatibility between CentOS and Debian to
support dual OS development.

Test Plan:
 - Build package in Debian
 - Include package in Debian ISO
 - Install ISO and confirm contents of /etc/puppet/puppet.conf

Change-Id: Ibfc58ed64a413da5620a2f05247822ef76271ef7
Story: 2009101
Task: 44576
Signed-off-by: Robert Church <robert.church@windriver.com>
2022-02-22 20:56:18 -05:00

50 lines
1.7 KiB
Diff

From 4cd14c94ddc02b9b3aa1f25a038db657c5f9235e Mon Sep 17 00:00:00 2001
From: Charles Short <charles.short@windriver.com>
Date: Tue, 26 Oct 2021 11:54:45 -0400
Subject: [PATCH 1/2] Remove default hiera config
Remove the default puppet hiera.yaml so it wont conflict
with the hiera.yaml shipped in the puppet-manifests
package.
Signed-off-by: Charles Short <charles.short@windriver.com>
---
debian/puppet.install | 1 -
debian/rules | 4 +++-
2 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/debian/puppet.install b/debian/puppet.install
index 323c342..b338ec1 100644
--- a/debian/puppet.install
+++ b/debian/puppet.install
@@ -3,5 +3,4 @@
/usr/lib/ruby/vendor_ruby/*
/usr/share/puppet/locale
ext/ldap/puppet.schema /etc/ldap/schema
-debian/conffiles/hiera.yaml /etc/puppet
debian/conffiles/puppet.conf /etc/puppet
diff --git a/debian/rules b/debian/rules
index 60100a2..c0eda26 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,13 +19,15 @@ override_dh_auto_install:
rm -vfr debian/tmp/usr/lib/ruby/vendor_ruby/puppet/vendor/rgen/
rm -vfr debian/tmp/usr/lib/ruby/vendor_ruby/puppet/vendor/deep_merge/
rm -vfr debian/tmp/usr/lib/ruby/vendor_ruby/puppet/vendor/pathspec/LICENSE
+ # We dont ship the default since it conflics with puppet-manifests
+ rm -vfr debian/tmp/etc/puppet/hiera.yaml
override_dh_auto_build:
dh_auto_build
HOME=$$(mktemp -d) LC_ALL=C.UTF-8 rake gen_manpages
override_dh_install:
- dh_install -Xusr/share/man
+ dh_install -Xusr/share/man -Xetc/puppet/hiera.yaml
mv debian/puppet-master-passenger/usr/share/puppet-master-passenger/example-passenger-vhost.conf \
debian/puppet-master-passenger/usr/share/puppet-master-passenger/apache2.site.conf.tmpl
--
2.16.6