589e8020db
This commit results in no change to actual code. It cleans up the following issues in the meta patches: - some patches generated fuzz and offset warnings - patch file names do not match that generated by git format-patch - some patches were not in git format, did not have a proper git header - some patches were not signed off by anybody - file names contained grub2 which is redundant - one patch added a blank line to the end of a file generating a warning, and a subsequent patch removed it. This has now been squashed out. There are 13 patches in total, they were numbered 1-14 with 4 being absent. They are now numbered 1-13. Verification: Built and captured the output, verified that there are no more fuzz and offset warnings. Closes-Bug: 1959037 Change-Id: I8056adf3ee96dc036262aa8c2d9eecfc353cc5ba Signed-off-by: Jim Somerville <Jim.Somerville@windriver.com>
56 lines
2.0 KiB
Diff
56 lines
2.0 KiB
Diff
From f51ca13eb123f7217426eb0b6d0c4a44b908725a Mon Sep 17 00:00:00 2001
|
|
Message-Id: <f51ca13eb123f7217426eb0b6d0c4a44b908725a.1643237526.git.Jim.Somerville@windriver.com>
|
|
In-Reply-To: <8b5576704440696a7c8f1b00735217bf1745b6a1.1643237526.git.Jim.Somerville@windriver.com>
|
|
References: <8b5576704440696a7c8f1b00735217bf1745b6a1.1643237526.git.Jim.Somerville@windriver.com>
|
|
From: slin14 <shuicheng.lin@intel.com>
|
|
Date: Fri, 17 Aug 2018 23:28:59 +0800
|
|
Subject: [PATCH 03/13] remove debug pkgs
|
|
|
|
Signed-off-by: slin14 <shuicheng.lin@intel.com>
|
|
Signed-off-by: Jim Somerville <Jim.Somerville@windriver.com>
|
|
---
|
|
SPECS/grub2.spec | 20 --------------------
|
|
1 file changed, 20 deletions(-)
|
|
|
|
diff --git a/SPECS/grub2.spec b/SPECS/grub2.spec
|
|
index c323a2a..38515ac 100644
|
|
--- a/SPECS/grub2.spec
|
|
+++ b/SPECS/grub2.spec
|
|
@@ -182,7 +182,6 @@ rm -f grub-%{tarversion}/util/grub-setpassword.in.orig
|
|
%install
|
|
set -e
|
|
rm -fr $RPM_BUILD_ROOT
|
|
-
|
|
%do_common_install
|
|
%if 0%{with_efi_arch}
|
|
%do_efi_install %{grubefiarch} %{grubefiname} %{grubeficdname}
|
|
@@ -210,25 +209,6 @@ cat << EOF > ${RPM_BUILD_ROOT}%{_sysconfdir}/prelink.conf.d/grub2.conf
|
|
-b /usr/sbin/grub2-sparc64-setup
|
|
EOF
|
|
|
|
-# Don't run debuginfo on all the grub modules and whatnot; it just
|
|
-# rejects them, complains, and slows down extraction.
|
|
-%global finddebugroot "%{_builddir}/%{?buildsubdir}/debug"
|
|
-
|
|
-%global dip RPM_BUILD_ROOT=%{finddebugroot} %{__debug_install_post}
|
|
-%define __debug_install_post ( \
|
|
- mkdir -p %{finddebugroot}/usr \
|
|
- mv ${RPM_BUILD_ROOT}/usr/bin %{finddebugroot}/usr/bin \
|
|
- mv ${RPM_BUILD_ROOT}/usr/sbin %{finddebugroot}/usr/sbin \
|
|
- %{dip} \
|
|
- install -m 0755 -d %{buildroot}/usr/lib/ %{buildroot}/usr/src/ \
|
|
- cp -al %{finddebugroot}/usr/lib/debug/ \\\
|
|
- %{buildroot}/usr/lib/debug/ \
|
|
- cp -al %{finddebugroot}/usr/src/debug/ \\\
|
|
- %{buildroot}/usr/src/debug/ ) \
|
|
- mv %{finddebugroot}/usr/bin %{buildroot}/usr/bin \
|
|
- mv %{finddebugroot}/usr/sbin %{buildroot}/usr/sbin \
|
|
- %{nil}
|
|
-
|
|
%clean
|
|
rm -rf $RPM_BUILD_ROOT
|
|
|
|
--
|
|
2.29.2
|
|
|