242e6630af
Python NSS module is not buildable by pip on Debian/bullseye and requires patches. The debian package for this module contains the required fixes, but contains 2 other problems: - it builds only the PY3-version of itself - it (incorrectly) doesn't install pip metadata, making it "invisible" by pip Solution: import python-nss from debian/bullseye + add patches that fix the above problems. TESTS ================ Build package in debian environment Story: 2009897 Task: 44691 Signed-off-by: Davlet Panech <davlet.panech@windriver.com> Change-Id: I65ab9b967e38340939bd99c389b72820ee17571b
58 lines
1.9 KiB
Diff
58 lines
1.9 KiB
Diff
From 58830c2a305e6d1b931b46700e9af04647c85198 Mon Sep 17 00:00:00 2001
|
|
From: Davlet Panech <davlet.panech@windriver.com>
|
|
Date: Wed, 6 Apr 2022 01:01:17 +0000
|
|
Subject: [PATCH 2/2] Build the python2 variant
|
|
|
|
Signed-off-by: Davlet Panech <davlet.panech@windriver.com>
|
|
---
|
|
debian/control | 15 +++++++++++++++
|
|
debian/rules | 2 +-
|
|
2 files changed, 16 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/debian/control b/debian/control
|
|
index c42e324..fb407b1 100644
|
|
--- a/debian/control
|
|
+++ b/debian/control
|
|
@@ -5,6 +5,7 @@ Maintainer: Debian FreeIPA Team <pkg-freeipa-devel@lists.alioth.debian.org>
|
|
Uploaders: Timo Aaltonen <tjaalton@debian.org>
|
|
Build-Depends: debhelper-compat (= 12),
|
|
dh-python,
|
|
+ python-all-dev,
|
|
python3-all-dev,
|
|
libnss3-dev,
|
|
Standards-Version: 4.5.1
|
|
@@ -25,3 +26,17 @@ Description: Python3 bindings for Network Security Services (NSS)
|
|
and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509 v3
|
|
certificates, and other security standards. Specific NSS
|
|
implementations have been FIPS-140 certified.
|
|
+
|
|
+Package: python-nss
|
|
+Architecture: any
|
|
+Provides: ${python:Provides}, ${python-nss:Provides}
|
|
+Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends}
|
|
+Description: Python2 bindings for Network Security Services (NSS)
|
|
+ This package provides Python2 bindings for Network Security Services (NSS)
|
|
+ and the Netscape Portable Runtime (NSPR).
|
|
+ .
|
|
+ NSS is a set of libraries supporting security-enabled client and
|
|
+ server applications. Applications built with NSS can support SSL v2
|
|
+ and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509 v3
|
|
+ certificates, and other security standards. Specific NSS
|
|
+ implementations have been FIPS-140 certified.
|
|
diff --git a/debian/rules b/debian/rules
|
|
index ef6314b..fa4eb42 100755
|
|
--- a/debian/rules
|
|
+++ b/debian/rules
|
|
@@ -7,7 +7,7 @@
|
|
export PYBUILD_NAME=nss
|
|
|
|
%:
|
|
- dh $@ --with python3 --buildsystem=pybuild
|
|
+ dh $@ --with python2,python3 --buildsystem=pybuild
|
|
|
|
override_dh_auto_clean:
|
|
|
|
--
|
|
2.30.2
|
|
|