integ/kubernetes/docker-distribution/debian/deb_patches/0003-Override-docker-registry-service.patch
Dan Voiculeasa 90a88fec47 Disable docker-registry service
This work is part of Debian integration effort.
This removes a bootstrap issue.

Docker registry service is managed by puppet.
Disable the service, otherwise it will start and listen on the same
port keystone will, thus preventing keystone from starting.

Test:
PASS: build-pkgs & build-image
PASS: bootstrap

Change-Id: Ia7a4a8525af022ebff607700c42812611f3043e8
Signed-off-by: Dan Voiculeasa <dan.voiculeasa@windriver.com>
2022-04-05 12:48:02 +03:00

30 lines
865 B
Diff

From ec4d2b9704df16e3ffe4256b3eae6b7bd8d25807 Mon Sep 17 00:00:00 2001
From: Charles Short <charles.short@windriver.com>
Date: Sun, 5 Dec 2021 13:33:26 +0000
Subject: [PATCH] Override docker-registry service
Prevent the docker-registry from starting when package is installed.
Signed-off-by: Charles Short <charles.short@windriver.com>
---
debian/rules | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/debian/rules b/debian/rules
index 8383ccd..f02c9ef 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,5 +17,9 @@ override_dh_auto_test:
# health/checks hit the internet, and thus fail
#DH_GOLANG_EXCLUDES='distribution/registry/handlers health/checks' dh_auto_test -- -test.short
+override_dh_installsystemd:
+ dh_installsystemd -p docker-registry --no-enable docker-registry.service
+
%:
dh $@ --buildsystem=golang --with=golang
+
--
2.30.2