integ/python/python3.9/debian/deb_patches/0001-adding-timeout-regrtest.patch
Dostoievski Batista 14affb5870 python3.9: Add timeout regrtest
Even after disabling python3.9 specific test we are
seeing the build process getting stuck on the test run again.
On previous run all the test took less then 3 minute, this
change aim to set a timeout of 4 minutes to every test
run by regrtest.py.

Test Plan:
PASS: Build the package with build-pkgs -c -p python3.9 successfully

Partial-Bug: 2009722

Signed-off-by: Dostoievski Batista <dostoievski.albinobatista@windriver.com>
Change-Id: Ibf286223e5c2cd6616f7cc1c98b6953808d774b1
2023-04-12 08:29:08 -03:00

24 lines
755 B
Diff

From b8d2158ba83561554bbc88bcdeb7de16eb776371 Mon Sep 17 00:00:00 2001
From: Dostoievski Batista <dostoievski.albinobatista@windriver.com>
Date: Mon, 10 Apr 2023 16:31:49 -0300
Subject: [PATCH] Adding timeout for regrtest.py
Signed-off-by: Dostoievski Batista <dostoievski.albinobatista@windriver.com>
---
debian/rules | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/debian/rules b/debian/rules
index 1d632f2..1bb7f39 100755
--- a/debian/rules
+++ b/debian/rules
@@ -316,7 +316,7 @@ PROFILE_EXCLUDES += \
# TODO: update profiled-build.diff to support --next
# --next=20
PROFILE_TASK = ../Lib/test/regrtest.py \
- -s \
+ -s --timeout 240 \
-j 1 -unone,decimal \
-x $(sort $(TEST_EXCLUDES) $(PROFILE_EXCLUDES))
--
2.25.1