
Intel listed total 28 commits that need us to back port. There are 9 commits that are already included in our code base. The commit "ice: Add support for E825-C TS PLL handling" will not be back ported since we're not dealing with E825 for 24.09. So we need back port 18 commits. These commits were introduced in linux-6.9.y and linux-6.10.y. To back port these 18 commits successfully, we totally back ported 37 upstream commits. 1) The patches 1-15 are cherry picked to fix the conflicts for patch 16 ("ice: introduce PTP state machine") and patch 36 "ice: Introduce ice_ptp_hw struct". Also will be helpful for the subsequent commits back porting. 2) The patches 24-27 are cherry picked to fix the conflicts for patch 28 ("ice: Fix debugfs with devlink reload") 3) The minor adjust was done for the patches 17, 21, 23 and 33 to fit with the context change. Verification: - installs from iso succeed on servers with ice(Intel Ethernet Controller E810-XXVDA4T Westport Channel) and i40e hw(Intel Ethernet Controller X710) for rt and std. - interfaces are up and pass packets for rt and std. - create vfs, ensure that they are picked up by the new iavf driver and that the interface can come up and pass packets on rt and std system. - Check dmesg to see DDP package is loaded successfully and the version is 1.3.36.0 for rt and std. Story: 2011056 Task: 50950 Change-Id: I9aef0378ea01451684341093a167eaead3edc458 Signed-off-by: Jiping Ma <jiping.ma2@windriver.com>
192 lines
6.4 KiB
Diff
192 lines
6.4 KiB
Diff
From 9411c5b82a7196b9712488631fd14e67e2d919fa Mon Sep 17 00:00:00 2001
|
|
From: Jacob Keller <jacob.e.keller@intel.com>
|
|
Date: Thu, 25 Jan 2024 13:57:54 -0800
|
|
Subject: [PATCH 21/36] ice: factor out ice_ptp_rebuild_owner()
|
|
|
|
The ice_ptp_reset() function uses a goto to skip past clock owner
|
|
operations if performing a PF reset or if the device is not the clock
|
|
owner. This is a bit confusing. Factor this out into
|
|
ice_ptp_rebuild_owner() instead.
|
|
|
|
The ice_ptp_reset() function is called by ice_rebuild() to restore PTP
|
|
functionality after a device reset. Follow the convention set by the
|
|
ice_main.c file and rename this function to ice_ptp_rebuild(), in the
|
|
same way that we have ice_prepare_for_reset() and
|
|
ice_ptp_prepare_for_reset().
|
|
|
|
Signed-off-by: Jacob Keller <jacob.e.keller@intel.com>
|
|
Signed-off-by: Karol Kolacinski <karol.kolacinski@intel.com>
|
|
Reviewed-by: Jacob Keller <jacob.e.keller@intel.com>
|
|
Reviewed-by: Simon Horman <horms@kernel.org>
|
|
Tested-by: Pucha Himasekhar Reddy <himasekharx.reddy.pucha@intel.com> (A Contingent worker at Intel)
|
|
Signed-off-by: Tony Nguyen <anthony.l.nguyen@intel.com>
|
|
Signed-off-by: Paolo Abeni <pabeni@redhat.com>
|
|
(cherry picked from commit 803bef817807d2d36c930dada20c96fffae0dd19)
|
|
[Adjust ice_ptp.h with the context change.]
|
|
Signed-off-by: Jiping Ma <jiping.ma2@windriver.com>
|
|
---
|
|
drivers/net/ethernet/intel/ice/ice_main.c | 2 +-
|
|
drivers/net/ethernet/intel/ice/ice_ptp.c | 62 ++++++++++++++---------
|
|
drivers/net/ethernet/intel/ice/ice_ptp.h | 6 +--
|
|
3 files changed, 42 insertions(+), 28 deletions(-)
|
|
|
|
diff --git a/drivers/net/ethernet/intel/ice/ice_main.c b/drivers/net/ethernet/intel/ice/ice_main.c
|
|
index d5321410f2d7..a04dcc89c35d 100644
|
|
--- a/drivers/net/ethernet/intel/ice/ice_main.c
|
|
+++ b/drivers/net/ethernet/intel/ice/ice_main.c
|
|
@@ -7533,7 +7533,7 @@ static void ice_rebuild(struct ice_pf *pf, enum ice_reset_req reset_type)
|
|
* fail.
|
|
*/
|
|
if (test_bit(ICE_FLAG_PTP_SUPPORTED, pf->flags))
|
|
- ice_ptp_reset(pf, reset_type);
|
|
+ ice_ptp_rebuild(pf, reset_type);
|
|
|
|
if (ice_is_feature_supported(pf, ICE_F_GNSS))
|
|
ice_gnss_init(pf);
|
|
diff --git a/drivers/net/ethernet/intel/ice/ice_ptp.c b/drivers/net/ethernet/intel/ice/ice_ptp.c
|
|
index c6e9d77fc59b..780aa242c86b 100644
|
|
--- a/drivers/net/ethernet/intel/ice/ice_ptp.c
|
|
+++ b/drivers/net/ethernet/intel/ice/ice_ptp.c
|
|
@@ -2655,11 +2655,13 @@ void ice_ptp_prepare_for_reset(struct ice_pf *pf, enum ice_reset_req reset_type)
|
|
}
|
|
|
|
/**
|
|
- * ice_ptp_reset - Initialize PTP hardware clock support after reset
|
|
+ * ice_ptp_rebuild_owner - Initialize PTP clock owner after reset
|
|
* @pf: Board private structure
|
|
- * @reset_type: the reset type being performed
|
|
+ *
|
|
+ * Companion function for ice_ptp_rebuild() which handles tasks that only the
|
|
+ * PTP clock owner instance should perform.
|
|
*/
|
|
-void ice_ptp_reset(struct ice_pf *pf, enum ice_reset_req reset_type)
|
|
+static int ice_ptp_rebuild_owner(struct ice_pf *pf)
|
|
{
|
|
struct ice_ptp *ptp = &pf->ptp;
|
|
struct ice_hw *hw = &pf->hw;
|
|
@@ -2667,32 +2669,21 @@ void ice_ptp_reset(struct ice_pf *pf, enum ice_reset_req reset_type)
|
|
u64 time_diff;
|
|
int err;
|
|
|
|
- if (ptp->state == ICE_PTP_READY) {
|
|
- ice_ptp_prepare_for_reset(pf, reset_type);
|
|
- } else if (ptp->state != ICE_PTP_RESETTING) {
|
|
- err = -EINVAL;
|
|
- dev_err(ice_pf_to_dev(pf), "PTP was not initialized\n");
|
|
- goto err;
|
|
- }
|
|
-
|
|
- if (reset_type == ICE_RESET_PFR || !ice_pf_src_tmr_owned(pf))
|
|
- goto pfr;
|
|
-
|
|
err = ice_ptp_init_phc(hw);
|
|
if (err)
|
|
- goto err;
|
|
+ return err;
|
|
|
|
/* Acquire the global hardware lock */
|
|
if (!ice_ptp_lock(hw)) {
|
|
err = -EBUSY;
|
|
- goto err;
|
|
+ return err;
|
|
}
|
|
|
|
/* Write the increment time value to PHY and LAN */
|
|
err = ice_ptp_write_incval(hw, ice_base_incval(pf));
|
|
if (err) {
|
|
ice_ptp_unlock(hw);
|
|
- goto err;
|
|
+ return err;
|
|
}
|
|
|
|
/* Write the initial Time value to PHY and LAN using the cached PHC
|
|
@@ -2708,7 +2699,7 @@ void ice_ptp_reset(struct ice_pf *pf, enum ice_reset_req reset_type)
|
|
err = ice_ptp_write_init(pf, &ts);
|
|
if (err) {
|
|
ice_ptp_unlock(hw);
|
|
- goto err;
|
|
+ return err;
|
|
}
|
|
|
|
/* Release the global hardware lock */
|
|
@@ -2717,11 +2708,39 @@ void ice_ptp_reset(struct ice_pf *pf, enum ice_reset_req reset_type)
|
|
if (!ice_is_e810(hw)) {
|
|
/* Enable quad interrupts */
|
|
err = ice_ptp_cfg_phy_interrupt(pf, true, 1);
|
|
+ if (err)
|
|
+ return err;
|
|
+
|
|
+ ice_ptp_restart_all_phy(pf);
|
|
+ }
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+/**
|
|
+ * ice_ptp_rebuild - Initialize PTP hardware clock support after reset
|
|
+ * @pf: Board private structure
|
|
+ * @reset_type: the reset type being performed
|
|
+ */
|
|
+void ice_ptp_rebuild(struct ice_pf *pf, enum ice_reset_req reset_type)
|
|
+{
|
|
+ struct ice_ptp *ptp = &pf->ptp;
|
|
+ int err;
|
|
+
|
|
+ if (ptp->state == ICE_PTP_READY) {
|
|
+ ice_ptp_prepare_for_reset(pf, reset_type);
|
|
+ } else if (ptp->state != ICE_PTP_RESETTING) {
|
|
+ err = -EINVAL;
|
|
+ dev_err(ice_pf_to_dev(pf), "PTP was not initialized\n");
|
|
+ goto err;
|
|
+ }
|
|
+
|
|
+ if (ice_pf_src_tmr_owned(pf) && reset_type != ICE_RESET_PFR) {
|
|
+ err = ice_ptp_rebuild_owner(pf);
|
|
if (err)
|
|
goto err;
|
|
}
|
|
|
|
-pfr:
|
|
/* Init Tx structures */
|
|
if (ice_is_e810(&pf->hw)) {
|
|
err = ice_ptp_init_tx_e810(pf, &ptp->port.tx);
|
|
@@ -2736,11 +2755,6 @@ void ice_ptp_reset(struct ice_pf *pf, enum ice_reset_req reset_type)
|
|
|
|
ptp->state = ICE_PTP_READY;
|
|
|
|
- /* Restart the PHY timestamping block */
|
|
- if (!test_bit(ICE_PFR_REQ, pf->state) &&
|
|
- ice_pf_src_tmr_owned(pf))
|
|
- ice_ptp_restart_all_phy(pf);
|
|
-
|
|
/* Start periodic work going */
|
|
kthread_queue_delayed_work(ptp->kworker, &ptp->work, 0);
|
|
|
|
diff --git a/drivers/net/ethernet/intel/ice/ice_ptp.h b/drivers/net/ethernet/intel/ice/ice_ptp.h
|
|
index 1486a0b3b016..352405a2daf2 100644
|
|
--- a/drivers/net/ethernet/intel/ice/ice_ptp.h
|
|
+++ b/drivers/net/ethernet/intel/ice/ice_ptp.h
|
|
@@ -317,7 +317,7 @@ enum ice_tx_tstamp_work ice_ptp_process_ts(struct ice_pf *pf);
|
|
void
|
|
ice_ptp_rx_hwtstamp(struct ice_rx_ring *rx_ring,
|
|
union ice_32b_rx_flex_desc *rx_desc, struct sk_buff *skb);
|
|
-void ice_ptp_reset(struct ice_pf *pf, enum ice_reset_req reset_type);
|
|
+void ice_ptp_rebuild(struct ice_pf *pf, enum ice_reset_req reset_type);
|
|
void ice_ptp_prepare_for_reset(struct ice_pf *pf,
|
|
enum ice_reset_req reset_type);
|
|
void ice_ptp_init(struct ice_pf *pf);
|
|
@@ -355,8 +355,8 @@ static inline void
|
|
ice_ptp_rx_hwtstamp(struct ice_rx_ring *rx_ring,
|
|
union ice_32b_rx_flex_desc *rx_desc, struct sk_buff *skb) { }
|
|
|
|
-static inline void ice_ptp_reset(struct ice_pf *pf,
|
|
- enum ice_reset_req reset_type)
|
|
+static inline void ice_ptp_rebuild(struct ice_pf *pf,
|
|
+ enum ice_reset_req reset_type)
|
|
{
|
|
}
|
|
|
|
--
|
|
2.43.0
|
|
|