
As part of the STX-Openstack upversion to ANTELOPE, the python- novaclient is being upversioned to version 18.3.0-2, which is the latest supported on ANTELOPE [1]. All patches were updated in order to make the package buildable in the new version. This change also adds the sha256sum field to the downloader path, as it is being recommended to use it in the place of the md5sum. [1] https://releases.openstack.org/antelope/#antelope-python-novaclient Test Plan: PASS: Build the python-novaclient package Story: 2010715 Task: 48136 Change-Id: Idaa50c75a3681ca764eb7c644dcc999d7425e6c5 Signed-off-by: Lucas de Ataides <lucas.deataidesbarreto@windriver.com>
56 lines
1.9 KiB
Diff
56 lines
1.9 KiB
Diff
From eeb0bba5f0f516a45ee58993b01bbec99082c9db Mon Sep 17 00:00:00 2001
|
|
From: Charles Short <charles.short@windriver.com>
|
|
Date: Tue, 26 Oct 2021 16:59:10 +0000
|
|
Subject: [PATCH 1/1] Add wheel support
|
|
|
|
Add python3-novaclient-wheel package.
|
|
|
|
Signed-off-by: Charles Short <charles.short@windriver.com>
|
|
---
|
|
debian/control | 18 ++++++++++++++++++
|
|
debian/rules | 2 +-
|
|
2 files changed, 19 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/debian/control b/debian/control
|
|
index a5f1de8d..c8a42a08 100644
|
|
--- a/debian/control
|
|
+++ b/debian/control
|
|
@@ -92,3 +92,21 @@ Description: client library for OpenStack Compute API - 3.x
|
|
Compute (Nova) through the OpenStack Compute API.
|
|
.
|
|
This package provides the Python 3.x module.
|
|
+
|
|
+Package: python3-novaclient-wheel
|
|
+Architecture: all
|
|
+Depends:
|
|
+ python3-wheel,
|
|
+ ${misc:Depends},
|
|
+ ${python3:Depends},
|
|
+Description: client library for OpenStack Compute API - 3.x
|
|
+ OpenStack Compute, codenamed Nova, is a cloud computing fabric controller
|
|
+ designed to be modular and easy to extend and adapt. In addition to its
|
|
+ "native" OpenStack API, it also supports the Amazon EC2 API, and it supports
|
|
+ many different database backends (including SQLite, MySQL, and PostgreSQL),
|
|
+ hypervisors (KVM, Xen), and user directory systems (LDAP, SQL).
|
|
+ .
|
|
+ Python novaclient library and nova CLI tool for interacting with OpenStack
|
|
+ Compute (Nova) through the OpenStack Compute API.
|
|
+ .
|
|
+ This package contains the Python3 Wheel.
|
|
diff --git a/debian/rules b/debian/rules
|
|
index 67bcf5b9..76eb7f51 100755
|
|
--- a/debian/rules
|
|
+++ b/debian/rules
|
|
@@ -12,7 +12,7 @@ override_dh_auto_build:
|
|
echo "Do nothing..."
|
|
|
|
override_dh_auto_install:
|
|
- pkgos-dh_auto_install --no-py2
|
|
+ pkgos-dh_auto_install --no-py2 --wheel
|
|
install -D -m 0644 tools/nova.bash_completion $(CURDIR)/debian/python3-novaclient-doc/usr/share/bash-completion/completions/nova
|
|
rm -rf $(CURDIR)/debian/python-novaclient/usr/novaclient
|
|
|
|
--
|
|
2.25.1
|
|
|