Lucas de Ataides daf24aede7 Upversion python-openstackclient to v6.2.0-1
As part of the STX-Openstack upversion to ANTELOPE, the python-
openstackclient is being upversioned to version 6.2.0-1, which is the
latest supported on ANTELOPE [1].

All patches were updated so the package can be build. Note that on the
0002-Add-location-parameter-for-volume-backup-creation.patch, the end
part of the patch had to be removed [2], because on this new version,
the openstackclient it added a `**kwargs` argument [3], making it
unnecessary to specify the location argument.

This change also adds the sha256sum field to the downloader path, as it
is being recommended to use it in the place of the md5sum.

[1] https://releases.openstack.org/antelope/#antelope-python-openstackclient
[2] https://opendev.org/starlingx/openstack-armada-app/src/branch/master/upstream/openstack/python-openstackclient/debian/patches/0002-Add-location-parameter-for-volume-backup-creation.patch#L119
[3] https://salsa.debian.org/openstack-team/clients/python-openstackclient/-/blob/debian/6.2.0-1/openstackclient/volume/v2/volume_backup.py#L171

Test Plan:
PASS: Build the python-openstackclient package

Story: 2010715
Task: 48137

Change-Id: I3318b6b54acbcfce67a3f56edd7076fb1b5ac2a2
Signed-off-by: Lucas de Ataides <lucas.deataidesbarreto@windriver.com>
2023-06-22 14:14:27 -03:00

59 lines
1.7 KiB
Diff

From 25a9e8325b319aba48fe2f5703381af2823887f6 Mon Sep 17 00:00:00 2001
From: Charles Short <charles.short@windriver.com>
Date: Wed, 27 Oct 2021 13:57:42 +0000
Subject: [PATCH] Add wheel package
Add python3-openstackclient-wheel
Signed-off-by: Charles Short <charles.short@windriver.com>
---
debian/control | 21 +++++++++++++++++++++
debian/rules | 2 +-
2 files changed, 22 insertions(+), 1 deletion(-)
diff --git a/debian/control b/debian/control
index b1951c76..71609fa8 100644
--- a/debian/control
+++ b/debian/control
@@ -126,3 +126,24 @@ Description: OpenStack Command-line Client - Python 3.x
operations in OpenStack.
.
This package contains the Python 3.x module.
+
+Package: python3-openstackclient-wheel
+Architecture: all
+Depends:
+ python3-wheel,
+ ${misc:Depends},
+ ${python3:Depends},
+Recommends:
+ python-openstackclient-doc,
+ ${python3:Recommends},
+Description: OpenStack Command-line Client - Python 3.x
+ python-openstackclient is a unified command-line client for the OpenStack APIs.
+ It is a thin wrapper to the stock python-*client modules that implement the
+ actual REST API client actions.
+ .
+ This is an implementation of the design goals shown in
+ http://wiki.openstack.org/UnifiedCLI. The primary goal is to provide
+ a unified shell command structure and a common language to describe
+ operations in OpenStack.
+ .
+ This package contains the Python wheel.
diff --git a/debian/rules b/debian/rules
index 98193bc2..8c257cd8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,7 +12,7 @@ override_dh_auto_build:
echo "Do nothing..."
override_dh_auto_install:
- pkgos-dh_auto_install --no-py2
+ pkgos-dh_auto_install --no-py2 --wheel
# Generate bash completion
pkgos-gen-completion --py3 openstack
--
2.25.1